ANN in JustNN
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JUustNN

Tool per creare reti neurali che non ha bisogno di
programmazione

Flessibile, immediato e con possibilita di
interrogazioni

Fornisce aiuto per ottimizzare la rete e scegliere il
numero adeguato di nodi

Possibilita di importare dati (txt, xIs)
Download qui: http://justnn.com/

Anche versione «plus» a pagamento (scontata
per studenti): http://www.easynn.com/
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Elementi del workspace

e Barra dei bottoni. Ripropone i comandi presenti anche nei menu.
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Elementi del workspace

* Foglio dati

e = JustNN - [xor.tvg]

% File Edit View Zoom Defaults Insert Action Query Tidy Window Help

D & & BT [+ = @ |5k ®»@ =2 %% T QX
Input A ° iput B Output xq‘uﬁ_ewﬂ
uery false ralse false
[T:X e false false fale=
I:2 false true tru
I:3 true false Tru
I:4 true true false

o Column names (nomi o numeri)

o Row names (nomi 0 numeri)

° Cell values ((interi, reali, booleani o testi)
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Elementi del workspace

e Vista Network

e s T e——— T .
S
% File Edit View Zoom Defaults Insert &diuﬁ Qu_eq,r Iidy Window Help

0D & & @ l|.§éEEqE. }ﬁo%f%‘%h@“-} -1|||“:c,|"'q'“¢ %T@@i|0\°\|>_<’|
xor.tvg Het Input == 0.000000 |View network Negative Weight
JusthN s 0.000000 227 i
Node 0 details. Bias == 0.338557 Positive Weight
Error —=  0.000000 Insignificant Weight ------------

Left Click Node for Details.
0. Input A 2.

4, Output XOR

a °Input node
° | o e Hidden node (completamente connessi ai nodi di input e di
output

° Output node (connessi alle colonne di output della griglia)

Connection weights (il layer di input € completamente
connesso al primo layer nascosto.

Ogni connessione ha un peso che viene aggiornato mentre
larete sta apprendendo.

| layer nascosti sono completamente connessi ai hodi del
successivo layer hidden o al layer di output)
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Elementi del workspace

i Input Importance mostra I'importanza di ogni colonna di Input,

ovvero la somma dei pesi assoluti delle connessioni dal nodo di imput a
tutti | nodi del primo livello nascosto. Gli input sono mostrati in ordine
decrescente di importanza.

Diggers.tvq 154 cycles. Target error 0.0100 Average training error 0.009960
The first 6 of 6 Inputs in descending order.

Column Input Name Importance Relative Importance
1 Spades 8.2193987453
0 Diggers 6.9888917719
3 Temp 5.2355453725
2 Diameter 4.0235427629
5 % Clay 2.2157616254
4 % Rocks 0.7339824996
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Training Error
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Elementi del workspace

. Learning Progress mostra il progresso della rete nell’apprendimento. La

linea rossa e relativa all’errore massimo, la blu al minimo e la verde rappresenta la
media. La linea arancione & la media dell’errore di validazione.

First2.tvq Network is learning.
Maximum Average Minimum Validating error
e Learning rate: 0.600000
l/ Momentum: 0.800000
Maximum error: 0.952132
Average error: 0.195610
Minimum error: 0.000000
Target error: 0.010000
Training examples: 270
Validating examples: 99
Within 10.0% range. Score: 0
Correct if rounded. Score: 65
Validating: 65.66% OK
0 80 161 242 388 610 1015 1810 3200 5900 11600
Learning Cycles
Layer: Input Hidden 1 Output
Nodes: 6 6 1
Weights: 36
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Esempio 1

e Creeremo una ANN per lo
XOR, seguendo esempi e
dati messi a disposizione,

9 Did you know...

p rOp o pe I Ch | comi nCIa) JusthM can produce new Grids or add Example Rows by
impoting TXT, C3Y. XLE, BMP or binany files. 'File > New...!
d d J USt N N . 'File > Impan..

 (Occorre avviare JustNN e
seguire i passi proposti dal
primo esercizio cui si Geting Started |
accede con GETTING
START dalla dialog «Tips»
che compare all’avvio

W Shaow Tips at Start Mext Tip | Close
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Esempio 1

Ricordiamo che lo XOR (OR esclusivo) € un operatore logico il cui risultato e
VERO se uno degli input (ma NON entrambi) e VERO. Se gli input sono
entrambi veri, 'output ¢ falso.

Aprite il file xor.tvg nella cartella \JustNN\Samples. Il file contiene gia tutti
i dati.

Le colonne o le righe si selezionano con un click del mouse
sull’intestazione.

Il valore di input (riga QUERY) puo essere cambiato da vero a falso o
viceversa, utilizzando i bottoni 'Query > Increase’ e 'Query > Max' o 'Query
> Decrease' e 'Query > Min' sulla toolbar. Loutput non cambia perché la
rete non e ancora stata addestrata

Per avviare I'addestramento della rete, basta selezionare Action > Start
Learning o fare click sulla freccia verde sulla barra dei bottoni

'addestramento, in questo caso, durera una frazione di secondo.

Provate ora a cambiare i valori degli input (sulla riga QUERY) e vedrete che
stavolta i risultati cambiano (perché la rete e stata addestrata).
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Esempio 2

Impareremo come inserire i dati in una griglia.

Apriamo ora il file Clr Circle.tvq nella cartella
\JustNN\Samples.

Nella griglia che compare alcuni dati sono gia presenti. Altri
dovremo inserirli (dove vedete il punto interrogativo).

%Eile Edit View JZoom Defaults Insert Action Query Tidy Window Help

D & w @ ][ 2 e BT = PG| >
Red Freen BElue Yellow Cyan Magenta
Pair 1 1.0aa0a0 1.0aa0a0 d.0aaa0 true falze falze
Pair 2 Qd.00aa0 1.0000 1.0000 falze true false
Fair 3 1.0000 0.0000 2 false 2 true
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Esempio 2

Doppio click sulla cella all’incrocio tra Pair3 e Blue oppure click singolo e
scrivere 1. Compare la dialog box con il valore impostato. Diamo OK.

Stessa cosa con la cella all’incrocio tra Pair3 e Cyan. In questo caso basta
Scrive re f 3 JustNN - [CIr Circle.tvg]

%File Edit View Zoom Defaults Inset Action Query Tidy Window Help

La griglia € completa e

0 @ & B | ]|+ = & =8
Red Green Blue Tellow Cyan Magenta
Pair 1 1.0000 1.0000 0.0000 true false falae
Pair 2 0.0000 1.0000 1.0000 falae true false
Pair 3 1.0000 0.0000 2 false 2 true

- r s
Edit Grid [

Yalue

i

[Min: 0, Maoc 1] scaled [0, 1]=05

Example raw

JPair3

 Training © “alidatng © Quendng  © Exclude

Input Output colurmn

JElIue
* Beal  Integer © Bool O Text © |mage

* |nput " Qutput " Exclude

=

—
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Esempio 2

e Scegliere dal menu Action > New Network e nella dialog che compare
avremo dati gia impostati correttamente (JustNN aiuta determinando i
parametri ottimali)

. Mew Metwork [&r
e Click su OK.
Growth rate
Change ewvery cycles ar 5 seconds Q. Cancel ‘
Input layer Hidden layers Output layer
Created with Grow layer nurmber 1 W 2 I a Created with I
3nodes 3 nodes
from minirnurm nodes ‘3 |2 ‘2 |
connected to connected to
grid inputs to meximum nodes ‘4 |3 ‘3 gricl outputs

 Ladialog presenta gia i valori ottimali. Comunque la rete puo aver bisogno
di molto tempo per apprendere e potrebbe fornire pochi risultati in fase di
test. Una rete neurale migliore si puo ottenere selezionando 1 per grow
layer number e permettendo cosi a JustNN di determinare il numero
ottimo di nodi e connessioni. Raramente e necessario avere piu di un livello
di nodi nascosti, ma JustNN (selezionando 2 o 3) ne puo generare anche
piu di uno.

 Ogni volta che il periodo di cicli o secondi finisce, JustNN genera una nuova
rete neurale differente dalla precedente, salvando, alla fine, la migliore.
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Esempio 2

 Ladialog New Network permette di creare la rete ottimale per la griglia di
valori. Ogni rete e sottoposta a training per un breve periodo e viene
selezionata la rete che produce 'errore piu piccolo in fase di validazione del
training.

e AI'Ok compare un messaggio con un riepilogo delle caratteristiche della
rete creata.

e Click su “Si” nelle finestre che compaiono.

[ JustNN =) [ JustNn — =)
'.g.' Creating a network will reset learning. '.0.' Metwork created
= The Controls will be set to defaults. = Hidden layer 1 nodes: 4
i Hidden layer 2 nodes: 0
The AutoSave settings will be cleared. Hidden layer 3 nodes: 0 i
Do you want to continue? 1 Weight connections: 24 1
Do you want to set the Controls?
Si Mo
§| =
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Esempio 2

Quando viene creata una NN, JustNN imposta i valori in modo ottimale in base al contenuto della griglia.
Tutti | controlli che permettono queste impostazioni sono contenuti della Control dialog.

Il Learning Rate & impostato a 0.6 e puo essere cambiato con ogni valore da 0.1 a 10. Valori molto bassi
faranno si che la rete apprenda in modo lento e valori al di sopra di 1.5 spesso causeranno oscillazioni o
risultati errati.

Con un click su Optimize, JustNN determinera automaticamente il learning rate adeguato, provando (in
modo trasparente all’'utente) vari valori per qualche ciclo.

Check Decay per ridurre automaticamente il learning rate durante l'apprendimento se si verificano
apprendimento sbagliato o oscillazioni.

= =5 -
Controls I i

ili— e —— i —_ —

Learning Target error stops

Learning rate 0.6] [ Decay [ Optimize * Stop when Average erroris below T

tomentum 0a [~ Decay [ Optimize or © stopwhen All errars are below
Yalidating “alidating stops

cles before first walidatin cle 100
Cy - e [ Stop when 100 % ofthe validating examples
n a [
Cycles pervalidating cycle 100 are  Wihin |10 % of desired outputs

Select |0 examples at random from the or & Correct after rounding

Training examples = 3 ! )
Fixed period stops

Slow learning [ Stop after 20.0000  secands

I~ Delay learing cycles by |0 millisecs [~ Stopaon a cycles
oK | Cancel

L% P
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Esempio 2

Il Momentum e impostato a 0.8 e pu0 essere cambiato con ogni valore da 0 a 0.9. Check Optimize per
permettere a JustNN di determinare automaticamente il momento. Check Decay per ridurre automaticamente il
momento durante I'apprendimento se si verificano oscillazioni.

Il Target Error € impostato a 0.01 e puo essere cambiato con ogni valore da 0 a 0.9 ma i valori al di sopra di 0.2 di
solito sotto-addestrano la rete. Lapprendimento si ferma quando la media degli errori € al di sotto dell’errore
target.

JustNN usa parte dei dati (in modo random) per addestrare la rete, e parte per la validazione. Si puo indicare di
fermare I'apprendimento quando il target e raggiunto (es. 100%, o indicando un range specifico —da 0 a 50%)

Il parametro Slow learning fa si che I'apprendimento avvenga in modo piu lento (piu accurato?)

Controls I - L&J
———— . i e
Learning Target ermar stops
Leamning rate  [184 ™ Decay [ Optimize ' Stopwhen Awverage error is below
B 0.m
Momentum na ™ Decay [ Optimize or ° stopwhen All errors are below
Yalidating Yalidating stops
cles before firstwalidatin cle 100
Cyrlesh J [~ Stopwhen  |100 % of the validating examples
P |
Cycles perwvalidating cycle 100 are ¢ Within 10 o 5 dimsiie) ouEE
Select |0 examples at random from the or ¢ Correct after rounding

Training examples = 3 ! :
Fixed period stops

Slow learning [ Stop after e0.0000  seconds

[ Delaylearing cycles by |0 millisecs [~ Stop on 0 cycles
DK, | Cancel

|
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Esempio 2

'apprendimento € molto veloce e si ferma automaticamente.

Click sul menu View > Network per vedere la ANN creata.

Click su View>Grid per tornare alla griglia.
Ora la griglia puo accettare le query.

HEY JustNN - [Cr Circle.tvg]

%File Edit View Zoom Defaults Insert Action Query Tidy Window Help

Left Click Mode for Details.

a u » a = -— o =
D & & @ [|Aé a‘% _@_;»‘;r‘é‘%h@' -)-m|||‘.__|+Q1 . £ %
Clr Circle.tvg Net Input === 1.000000 Hegative Weight
JusthN mmm 1.000000 Positive Weight
Node 0 details. Bias == -0.419553 Sitive Wel
Error —a 0.000000 Insignificant Weight ------—------
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Esempio 3

'esempio 3 tratta | dati relativi a corse di cavalli. Ogni cavallo ha delle
caratteristiche (per riga) rilevate in gare differenti.

Seguendo lo stesso procedimento adottato per gli esempi precedenti, si
ottiene un modo per prevedere | risultati delle corse (ovviamente della
popolazione, cioe dei cavalli, rappresentati).

Stavolta per caricare il file useremo I'import
File > New per creare una griglia vuota

File > Import per importare i dati da Races.txt nella directory
\JustNN\Samples (I dati si possono importare anche da formati excel).

Selezionare nella dialog il delimitatore (es. TAB)

Indicare se le prime parole (& il nostro caso) contengono i nomi delle righe.
Click su OK

Nella seconda dialog click su Set names per creare le colonne e andare avanti
fino all’'ultima (nel nostro caso sappiamo che & la 6) il cui tipo (Type) va
cambiato in Output e click su OK.
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Esempio 3

Menu Action > New Network tiper creare la ANN
Click OK nella prima dialog che ormai conosciamo
Al messaggio “Creating a network will reset learning” rispondere SI’
Rispondere SI’ anche al messaggio successivo
Nella control dialog:
— Check su Optimize sia per il Learning Rate che per il Momentum

— Mettere 200 in “Select examples at random” per creare alcuni esempi di
validazione (lo fa JustNN in modo random - casuale)

Check “Stop on cycle” e mettere 1000. Poi click su OK
Rispondere SI’ per ottimizzare i controlli e SI’ per avviare 'apprendimento

Una volta finito I'apprendimento, menu View > Information per vedere | dettagli della
rete.

Click sul bottone Refresh per essere sicuri che i dettagli sono completi.
Guardate i risultati di validazione: dal 50 all’80% i risultati “predicted” sono corretti.

Chiudete la dialog informatio
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Esempio 3

Menu Insert > Querying Example Row

Se si apre la dialog 'Example Presets' fate click su OK per impostare i valori
a unknown (nella griglia appare '?‘).

Immettete Runners e Distance per una gara.
Selezionate la riga di query con un doppio click dove e scritto Q:0 in rosso

Ora menu Edit > Copy e poi Edit > Paste per creare una riga per ogni
cavallo (facciamone 3). Vedrete in Win, | possibili vincitori. Se ce n’e uno
solo, il risultato, ovviamente, € piu certo!

Nella cartella \JustNN\Samples troverete molti altri esempi.

Inoltre nella pagina da cui avete scaricato il programma e presente un
piccolo manuale di documenatazione.
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